Executive summary of OpenBSD setup cat /etc/rc.conf.local xenodm_flags= # Install time boot to X11 apmd_flags="-A" # Laptop power saving cat /etc/doas.conf # http://daemonforums.org/showthread.php?t=9774 permit nopass keith as root cmd mount permit nopass keith as root cmd umount permit nopass keith as root cmd reboot permit nopass keith as root cmd shutdown permit nopass keith as root cmd ntfs-3g # I think that this lets root run commands as me # without challenge for my password e.g. from # a script. I want to check that this is the # minimal permission required! permit nopass root as keith cmd xlock permit nopass root as keith cmd env cat /etc/wsconsctl.conf keyboard.bell.volume=0 Quiet the bell! and stop Xterm loading at startup cat /etc/X11//xenodm/Xsetup_0 #!/bin/sh # $OpenBSD: Xsetup_0,v 1.6 2019/06/29 13:33:06 espie Exp $ # xconsole -geometry 480x130-0-0 -daemon -notify -verbose -fn fixed -exitOnFail xsetroot -solid navyblue xset b off xset b 0 0 0 # install package openbsd-backgrounds # then uncomment: # # if test -x /usr/local/bin/openbsd-wallpaper # then # /usr/local/bin/openbsd-wallpaper # fi # sxpm OpenBSD.xpm & Lock screen after 5 minutes - straight out of the man page for xidle cat ~/.xsession xidle -delay 5 -sw -program "/usr/X11R6/bin/xlock -mode blank" \ -timeout 300 & xsetroot -solid WebGray exec fvwm Suspend and resume with WiFi reconnect - rough and ready cat /etc/apm/suspend #!/bin/sh doas -u keith env DISPLAY=:0 XAUTHORITY=/home/keith/.Xauthority xlock & cat /etc/apm/resume #!/bin/sh sleep 10 sh /etc/netstart The .fvwmrc stripped of comments - it works for me cat .fvwmrc | grep -v \# | grep -v ^$ ModulePath /usr/X11R6/lib/X11/fvwm PixmapPath /usr/X11R6/include/X11/pixmaps IconPath /usr/X11R6/include/X11/bitmaps DefaultFont -adobe-helvetica-bold-r-*-*-18-*-*-*-*-*-*-* DeskTopSize 1x1 EdgeResistance 10000 10000 EdgeScroll 0 0 AddToDecor Default HilightColor Black Orange Style "*" UseDecor Default, Color Silver/DimGray Style "*" BorderWidth 7, HandleWidth 7 Style "*" Icon unknown1.xpm, IconBox 0 -10 -280 -1 Style "*" MWMFunctions, MWMDecor, HintOverride Style "*" DecorateTransient, NoPPosition Style "*" SmartPlacement, StubbornPlacement, SloppyFocus MenuStyle Black LightGrey DarkGrey AddToMenu Programs + "Xterm" Exec exec xterm + "Firefox" Exec exec firefox + "Thunar" Exec exec thunar + "Leafpad" Exec exec leafpad + "Writer" Exec exec swriter + "Calc" Exec exec scalc + "Impress" Exec exec simpress + "Shotwell" Exec exec shotwell + "GIMP" Exec exec gimp + "Inkscape" Exec exec inkscape + "Audacious" Exec exec audacious + "Audacity" Exec exec audacity + "Volume" Popup Volume AddToMenu Volume "Volume" Title + "+5%%" Exec exec sndioctl output.level=+0.05 + "-5%%" Exec exec sndioctl output.level=-0.05 + "+1%%" Exec exec sndioctl output.level=+0.01 + "-1%%" Exec exec sndioctl output.level=-0.01 AddToMenu window "window" Title + "move" Move + "resize" Resize + "maximize" Maximize + "raise" Raise + "lower" Lower + "iconify" Iconify + "stick" Stick + "" Nop + "list" WindowList + "" Nop + "refresh" RefreshWindow + "close%" Close + "delete" Delete + "destroy" Destroy AddToMenu system "system" Title + "xlock" Exec exec xlock -mode blank + "Window" popup window + "recapture" Recapture + "xrdb -load" Exec xrdb -load $HOME/.Xdefaults + "restart" Restart fvwm + "quit" Quit + " " "" + " " "" + " " "" + "Shutdown" Popup Shutdown AddToMenu Shutdown " \!\! Shutdown \!\!" Title + " " " " + "Reboot" Exec exec doas reboot + " " " " + "Shutdown" Exec exec doas shutdown -ph now ClickTime 100 Mouse 1 R A Menu Programs Nop Mouse 2 R A WindowList Nop Mouse 3 R A Menu system Nop Mouse 0 1 A Menu window Close Mouse 1 T A Move-or-Raise Mouse 2 T A Move Mouse 3 T A Lower Mouse 0 2 A Maximize-Func Mouse 0 4 A Iconify Mouse 0 SF A Resize-or-Raise Mouse 1 I A Iconify Mouse 2 I A Move Mouse 3 I A Iconify Key F1 A M Menu Programs Key F2 A M Menu window Key F3 A M WindowList FvwmWinList Key W A 4 WindowList FvwmWinList Key P A 4 Menu Programs Key X A 4 Menu window AddToFunc Maximize-Func "M" Maximize + "C" Maximize 100 100 + "D" Maximize AddToFunc Move-or-Raise + "I" Raise + "M" Move + "D" Lower AddToFunc Resize-or-Raise + "I" Raise + "M" Resize + "D" Lower AddToFunc SelectWindow + I Focus + I Raise + I WarpToWindow 50 8p Key Tab A M Next (CurrentDesk !Iconic) SelectWindow Key Tab A SM Prev (CurrentDesk !Iconic) SelectWindow Style "Fvwm*" NoTitle, Sticky Style "Fvwm*" BorderWidth 2, CirculateSkipIcon, CirculateSkip Package selection is very personal pkg_info -mz audacious-- audacious-plugins-- audacity-- firefox-- gimp-- gnuplot-- groff-- inkscape-- leafpad-- libreoffice-- lynx-- mplayer-- nano-- ntfs_3g-- quirks-- scrot-- sct-- shotwell-- thunar-- unzip-- wget-- xpdf-- Xdefaults copypasta from the tubes cat ~/.Xdefaults ! $OpenBSD: dot.Xdefaults,v 1.3 2014/07/10 10:22:59 jasper Exp $ XTerm*loginShell:true ! ! Above automatically generated by OpenBSD (Xenodm?) ! Below pinched from ! https://scarygliders.net/2011/12/01/customize-xterm-the-original-and-best-terminal/?PageSpeed=noscript ! and adapted ! ! Font settings Xft.dpi: 96 Xft.autohint: 0 Xft.lcdfilter: lcddefault Xft.hintstyle: hintslight Xft.hinting: 1 Xft.antialias: 1 Xft.rgba: rgb ! xlock and xidle to provide screen lock ! https://undeadly.org/cgi?action=article;sid=20080607131856 XIdle.timeout: 300 XLock.mode: blank XLock.mousemotion: on XLock.nice: 19 ! Use a nice truetype font and size by default... xterm*faceName: DejaVu Sans Mono Book xterm*faceSize: 11 ! Every shell is a login shell by default (for inclusion of all necessary environment variables) xterm*loginshell: true ! I like a LOT of scrollback... xterm*savelines: 16384 ! double-click to select whole URLs :D xterm*charClass: 33:48,36-47:48,58-59:48,61:48,63-64:48,95:48,126:48 ! DOS-box colours... xterm*foreground: rgb:f8/f8/a8 xterm*background: rgb:00/00/00 xterm*color0: rgb:00/00/00 xterm*color1: rgb:a8/00/00 xterm*color2: rgb:00/a8/00 xterm*color3: rgb:a8/54/00 xterm*color4: rgb:00/00/a8 xterm*color5: rgb:a8/00/a8 xterm*color6: rgb:00/a8/a8 xterm*color7: rgb:a8/a8/a8 xterm*color8: rgb:54/54/54 xterm*color9: rgb:fc/54/54 xterm*color10: rgb:54/fc/54 xterm*color11: rgb:fc/fc/54 xterm*color12: rgb:54/54/fc xterm*color13: rgb:fc/54/fc xterm*color14: rgb:54/fc/fc xterm*color15: rgb:fc/fc/fc ! right hand side scrollbar... xterm*rightScrollBar: true xterm*ScrollBar: true ! stop output to terminal from jumping down to bottom of scroll again xterm*scrollTtyOutput: false